升级 python 2.6.6 系统到 2.7.10 版本完整详细文档 ,以及安装pip

2019-08-09 15:27:00
IDO老徐
原创
99



CentOS 6 系统默认 Python 版本是:2.6.6 

平时在使用中,某些库要求是 2.7.x 版本的库,记录 Python 升级到 2.7.x 过程 



1. 准备安装包,系统是最小化安装

# 下载安装依赖的相关包

[root@isTester.com ~]# yum install vim gcc make wget -y

[root@isTester.com ~]# yum install openssl-devel zlib-devel readline-devel sqlite-devel -y



# 下载

[root@isTester.com ~]# cd /usr/local/src

[root@isTester.com ~]# wget https://www.python.org/ftp/python/2.7.10/Python-2.7.10.tgz

# 解压

[root@isTester.com ~]# tar -zxvf Python-2.7.10.tgz

[root@isTester.com ~]# ls

Python-2.7.10  Python-2.7.10.tgz



2. 编译配置安装

[root@isTester.com ~]# cd Python-2.7.10

[root@isTester.com Python-2.7.10]# ./configure --enable-shared --enable-loadable-sqlite-extensions \

    --prefix=/usr/local/python27 --with-zlib --with-ssl

[root@isTester.com Python-2.7.10]# vim ./Modules/Setup    # 找到下边这一行内容,去掉注释

#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz

[root@isTester.com Python-2.7.10]# make && make install



3. 查看 python 版本信息

[root@isTester.com Python-2.7.10]# python -V

Python 2.6.6

# 版本依旧是 2.6.6



4. python2.7 替换旧版本

[root@isTester.com Python-2.7.10]# cd /usr/bin/


[root@isTester.com bin]# ls python* -l   

# 查找旧 python 版本信息

-rwxr-xr-x. 2 root root 4864 2  22 2013  python

lrwxrwxrwx. 1 root root    6 10 22 18:38 python2 -> python

-rwxr-xr-x. 2 root root 4864 2  22 2013  python2.6


[root@isTester.com bin]# mv /usr/bin/python /usr/bin/python2.6.6

[root@isTester.com bin]# ln -s /usr/local/python27/bin/python2.7 /usr/bin/python


[root@isTester.com bin]# ls python* -l

lrwxrwxrwx. 1 root root   33 10 23 00:01 python -> /usr/local/python27/bin/python2.7

lrwxrwxrwx. 1 root root    6 10 22 18:38 python2 -> python

-rwxr-xr-x. 2 root root 4864 2  22 2013 python2.6

-rwxr-xr-x. 2 root root 4864 2  22 2013 python2.6.6



5. 重新验证 Python 版本信息

[root@isTester.com bin]# python -V

Python 2.7.10

#可以看到,系统识别的 python 版本已经是 python 2.7.10


#如果执行 python -V 遇到如下报错:

python: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

# 原因:linux 系统默认没有把/usr/local/python27/lib路径加入动态库搜索路径

解决:

[root@isTester.com ~]# vim /etc/ld.so.conf

# 添加如下一行内容

/usr/local/python27/lib

[root@isTester.com ~]# ldconfig  

# 使新添加的路径生效


再次,重新验证 Python 版本信息

[root@isTester.com bin]# python -V

Python 2.7.10

#可以看到,系统识别的 python 版本已经是 python 2.7.10




二、解决 yum 兼容性问题

因为 yum 是不兼容 Python 2.7 的,所以 yum 不能正常工作,我们需要指定 yum Python 2.6

1. 升级 python yum 出现的问题

[root@isTester.com bin]# yum 

There was a problem importing one of the Python modules

required to run yum. The error leading to this problem was:

 No module named yum

... ... ... ...


2. 编辑 yum 配置文件

[root@isTester.com bin]# vim /usr/bin/yum

#!/usr/bin/python

# 第一行修改为 python2.6.6

#!/usr/bin/python2.6.6



3. 验证 yum 问题解决

[root@isTester.com bin]# yum repolist

Loaded plugins: fastestmirror

Existing lock /var/run/yum.pid: another copy is running as pid 15013.

…….

…….


#搞定


三、升级 python 后,安装 pip 工具

1. 下载安装

[root@isTester.com ~]# wget https://bootstrap.pypa.io/get-pip.py

[root@isTester.com ~]# python get-pip.py

2. 设置软连接

[root@isTester.com ~]# ln -s /usr/local/python27/bin/pip2.7 /usr/bin/pip

#如果/usr/bin/pip下文件已经存在,先 mv /usr/bin/pip /usr/bin/pip2.6.6,在执行如上。

 

本站申明

1. 本站点,所有文章,均为IDO老徐原创,拒绝转载 。

2. 右上角,搜索框,输入关键词,可快速检索你感兴趣的所有文章 。

文章分类
热门文章
最新文章
公众号2



想了解更多 ?

欢迎关注老徐的公众号

Tester & 职场人 & 5W人都在关注

软件测试从业者综合能力提升&择业加薪 

第一时间,更新至此公众号

简尚公众号

长按二维码/微信扫码  关注老徐

老徐私人微信957863300

有问题,随时留言


联系老徐
联系人: IDO老徐
Email: 957863300@qq.com
QQ: 957863300
微信: 957863300
微博: isTester
网址: isTester.com
地址: 中国 . 广东 . 深圳